Partial Degraded Performance for Subset of Instances

Incident Report for dataco.vet

Resolved

This incident has been resolved.
Posted Sep 10, 2025 - 09:26 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 09, 2025 - 16:07 EDT

Identified

Earlier today, we encountered an issue affecting the monitoring of several of our managed Postgres servers.

Microsoft has confirmed that the disruption was caused by a latency in their telemetry ingestion pipeline, which is responsible for collecting and displaying key performance metrics such as CPU usage, memory, and storage. This latency stemmed from a transient backend processing delay within the metrics collection service. We are actively working to stabilize the servers and restore full connectivity and monitoring capabilities.
Posted Sep 09, 2025 - 10:30 EDT
This incident affected: Batch API (CSV Export, Daylight, PIMS Data).